?

Log in

 
 
24 November 2008 @ 12:17 pm
Atom stream moving  
Now that we have moved out of the Six Apart data center, we have created a new home for our full Atom stream. The previous one contains an aggregate of many different sites' content, while the new one only contains LiveJournal specific.
Old URL:
http://updates.sixapart.com/atom-stream.xml
New URL:
http://atom.services.livejournal.com/atom-stream.xml

We are currently publishing to both streams, but sooner or later (possibly in as soon as a couple of weeks) we will stop publishing to the Six Apart stream, so we encourage you to migrate any tools that are using the old stream as soon as possible. If you notice any problems with the new stream when doing your migration, comment in reply to this entry and we will take a look.
 
 
 
geri: autumn roadgerimaple on November 27th, 2008 07:20 am (UTC)
I'm not much a "crawl-under-the-hood-of-my-computer" kind of geek, so please refrain from laughing at my ignorance to my face :). Anyhow, how (if at all) does this change affect Atom API stuff like LoudTwitter? It's supposed to batch-post my tweets to my LJ daily, and stopped working shortly after the move (last post that came through was Sunday night's). According to LoudTwitter's info page they're sending my stuff to

http://www.livejournal.com/interface/atom/post

However, they also refer to LJ as a SixApart product, which it isn't any longer. So my uneducated guess is that something shifted after Sunday night. Just wondering what that something might be, so I can get my batch tweeting going again.

thanks
のむら あしゅりー(ぴか)orphenzidane on November 27th, 2008 05:37 pm (UTC)
I second this. I haven't been seeing my Tweets on my LJ page since the move...
Brentthebrowncoat on November 28th, 2008 03:39 am (UTC)
Also having this issue.
Mackmack_at_home on November 28th, 2008 09:35 am (UTC)
Same here.
Gabysquaringkarma on November 29th, 2008 09:25 am (UTC)
I had my Tweets ship once (yesterday), but other than that Tweets from 24th to now haven't been shipped.

Oh and I have my Tweets shipped to my LJ via e-mail because I use a tag and custom pic for my Twittered posts.
Mejem_endured_fit on December 4th, 2008 06:22 pm (UTC)
Can you tag from an email post or do you add it later?
Gabysquaringkarma on December 4th, 2008 06:43 pm (UTC)
You can tag from an e-mail post. I have the following as my "text to add at the beginning of the post":

lj-userpic: billy/penny - texting is important
lj-tags: twittering

billy/penny - texting is important is the icon's keywords. twittering is the pre-set tag. Here's more about e-mail posting: http://www.livejournal.com/manage/emailpost.bml?mode=help The LJ headers and security should help you out. You can predetermine a mood as well.
RivenSky: Bones || Sweets to the rescue!rivensky on November 28th, 2008 05:22 am (UTC)
LoudTwitter has definitely been affected by the Atom move across the board. Every user is affected.

My question is, LoudTwitter calls the link (http://www.livejournal.com/interface/atom/post) a Atom API endpoint url. Is that the same as http://atom.services.livejournal.com/atom-stream.xml? If I replace the link will it start working?

If not, what is the new endpoint url?

Thanks!
Татьяна: Ravenclawta on November 29th, 2008 09:36 pm (UTC)
Yes. The same question!
Tupshin Harper: teslatupshin on November 30th, 2008 02:37 am (UTC)
The URL that LoudTwitter uses (http://www.livejournal.com/interface/atom/post) has not changed, and is not the same as the new http://atom.services.livejournal.com/atom-stream.xml URL. We know that some LoudTwitter posts have been making it to LiveJournal after the move, and nothing except the IP address of our servers has changed. I would suggest contacting LoudTwitter support and making them aware of the problem. It is possible that one or more of the DNS servers that they are using is incorrectly caching our old information.
Mejem_endured_fit on December 1st, 2008 10:05 pm (UTC)
Although the timing isn't right for the batch to post, I just had one post from Loud Twitter.

Not sure if a fix went out, but what I did was go into my Loud Twitter settings for time to post, etc.........hit ok (even without changes) and later on I noticed the batch posted to LJ. Perhaps this is a fluke. I'm curious to know if others have seen a fix or if my oddity made it work.

My batches post at 4AM making it another 12 hours for me to know if it will work with today's Tweets.

Good luck!!
a very caring potatomollydot on December 4th, 2008 12:50 pm (UTC)
I got one batch posted without doing that, but not at my usual time, and I've had nothing since. I tried changing my setting earlier today, including changing the time so that it would post soon after the change. It's more than two hours after the new time I put in now, and nothing. I'm going to change it back to my usual time and hope for the best.

According to his twitter feed, he's on holidays, so it could be he can't look into it properly.
Татьянаta on December 4th, 2008 05:43 pm (UTC)
lucky you are. my twitter doesn't do anything :(
Me: Fosters - Same Shit Different Dayjem_endured_fit on December 4th, 2008 06:23 pm (UTC)
Holidays....*sigh* Figures!

After my previous comment, I had a double post at an odd time the next day and nothing since.